Is tinymce/tinymce 4.1 vulnerable?

Composer · 11 releases from 4.1.0 to 4.1.10 · latest tinymce/tinymce is 8.10.1 · checked 2 Nov 2026

Yes: 14 known advisories

Yes. tinymce/tinymce 4.1.10, the last 4.1 release, is affected by 14 known security advisories (3 high, 11 medium), including CVE-2026-47761, CVE-2026-47762, CVE-2026-47759. Upgrade to 7.9.3 or later to fix all of them.

Upgrade with:composer require tinymce/tinymce:^7.9.3

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting tinymce/tinymce 4.1.10

  • HighCVE-2026-47761GHSA-vg35-5wq7-3x7w5 Jun 2026

    TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

    Affected
    <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
    Fixed in
    7.9.3, 8.5.1
  • HighCVE-2026-47762GHSA-v98h-vmpc-fpqv5 Jun 2026

    TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments

    Affected
    <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
    Fixed in
    7.9.3, 8.5.1
  • HighCVE-2026-47759GHSA-q742-qvgc-gc2f5 Jun 2026

    TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes

    Affected
    <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
    Fixed in
    7.9.3, 8.5.1
  • MediumCVE-2024-38356GHSA-9hcv-j9pv-qmph19 Jun 2024

    TinyMCE Cross-Site Scripting (XSS) vulnerability using noneditable_regexp option

    Affected
    <5.11.0 · >=6.0.0 <6.8.4 · >=7.0.0 <7.2.0
    Fixed in
    5.11.0, 6.8.4, 7.2.0
  • MediumCVE-2024-38357GHSA-w9jx-4g6g-rp7x19 Jun 2024

    TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements

    Affected
    <5.11.0 · >=6.0.0 <6.8.4 · >=7.0.0 <7.2.0
    Fixed in
    5.11.0, 6.8.4, 7.2.0
  • MediumCVE-2024-29203GHSA-438c-3975-5x3f26 Mar 2024

    TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes

    Affected
    <6.8.1
    Fixed in
    6.8.1
  • MediumCVE-2024-29881GHSA-5359-pvf2-pw7826 Mar 2024

    TinyMCE Cross-Site Scripting (XSS) vulnerability in handling external SVG files through Object or Embed elements

    Affected
    <7.0.0
    Fixed in
    7.0.0
  • MediumCVE-2023-48219GHSA-v626-r774-j7f815 Nov 2023

    TinyMCE vulnerable to mutation Cross-site Scripting via special characters in unescaped text nodes

    Affected
    <5.10.9 · >=6.0.0 <6.7.3
    Fixed in
    5.10.9, 6.7.3
  • MediumCVE-2023-45819GHSA-hgqx-r2hp-jr3819 Oct 2023

    TinyMCE XSS vulnerability in notificationManager.open API

    Affected
    >=6.0.0 <6.7.1 · <5.10.8
    Fixed in
    5.10.8, 6.7.1
  • MediumCVE-2023-45818GHSA-v65r-p3vv-jjfv19 Oct 2023

    TinyMCE mXSS vulnerability in undo/redo, getContent API, resetContent API, and Autosave plugin

    Affected
    >=6.0.0 <6.7.1 · <5.10.8
    Fixed in
    5.10.8, 6.7.1
  • MediumCVE-2022-23494GHSA-gg8r-xjwq-4w928 Dec 2022

    Cross-site scripting vulnerability in TinyMCE alerts

    Affected
    >=6.0.0 <6.3.1 · <5.10.7
    Fixed in
    5.10.7, 6.3.1
  • MediumCVE-2024-21910GHSA-r8hm-w5f7-wj392 Nov 2021

    Cross-site scripting vulnerability in TinyMCE plugins

    Affected
    <5.10.0
    Fixed in
    5.10.0
  • MediumCVE-2024-21908GHSA-5h9g-x5rv-25wg22 Oct 2021

    Cross-site scripting vulnerability in TinyMCE

    Affected
    <5.9.0
    Fixed in
    5.9.0
  • MediumCVE-2024-21911GHSA-w7jx-j77m-wp656 Jan 2021

    Cross-site scripting vulnerability in TinyMCE

    Affected
    <5.6.0
    Fixed in
    5.6.0

Which of your client projects are still on tinymce/tinymce 4.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact tinymce/tinymce version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other tinymce/tinymce versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.