Is tinymce/tinymce 8.1 vulnerable?

Composer · 3 releases from 8.1.0 to 8.1.2 · latest tinymce/tinymce is 8.10.1 · checked 2 Nov 2026

Yes: 3 known advisories

Yes. tinymce/tinymce 8.1.2, the last 8.1 release, is affected by 3 known security advisories (3 high), including CVE-2026-47761, CVE-2026-47762, CVE-2026-47759. Upgrade to 8.5.1 or later to fix all of them.

Upgrade with:composer require tinymce/tinymce:^8.5.1

Is your project affected?

Private repo? Upload its lockfile instead, or connect GitHub to check every repo.

Advisories affecting tinymce/tinymce 8.1.2

  • HighCVE-2026-47761GHSA-vg35-5wq7-3x7w5 Jun 2026

    TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

    Affected
    <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
    Fixed in
    7.9.3, 8.5.1
  • HighCVE-2026-47762GHSA-v98h-vmpc-fpqv5 Jun 2026

    TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments

    Affected
    <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
    Fixed in
    7.9.3, 8.5.1
  • HighCVE-2026-47759GHSA-q742-qvgc-gc2f5 Jun 2026

    TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes

    Affected
    <=5.10.9 · >=6.0.0 <7.9.3 · >=8.0.0 <8.5.1
    Fixed in
    7.9.3, 8.5.1

Which of your client projects are still on tinymce/tinymce 8.1?

NPMscan reads the lockfiles in every GitHub repo you pick, finds the exact tinymce/tinymce version each one installs, and checks it against these advisories. Each finding comes with the command that fixes it.

Other tinymce/tinymce versions

Advisory data from OSV.dev (opens OSV.dev in a new tab), which includes the GitHub Advisory Database. Release list from the Composer registry. Refreshed daily.